Talkatone

Knowledge Base

Important Information for Kindle users

Last Updated: Feb 16, 2018 12:12PM PST

Talkatone is no longer supported on Kindle devices. We apologize for the inconvenience this may cause you.

You should be able to access your Talkatone account next time you sign into your account on an iPhone or Android device.

Talkatone supports iOS v9.0+ and Android v4.2+

Supported mobile devices:   

iPhone (4S, 5, 5C, 5S, 6, 6+, 6S, 6S+, SE, 7, 7+, 8, 8+, X) running iOS 9.0+ 

Android: 4.2+, armv7 or x86 CPU 

iPad (2nd, 3rd & 4th Gen; Air, Air2, Pro, iPad 2017) running iOS 9.0+ 

iPod Touch (5th Gen, 6th Gen) running iOS 9.0+

If you have any further questions about this, contact us here.

support_desk_com@talkme.im
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en_us/portal/articles/autocomplete